WDCP升级5.2.17到5.3.17同时编译pdo_mysql

WDCP中,把php5.2.17升级到5.3.17时,原先的pdo_mysql和memcache扩展都失效了,需要重新编译安装。这个过程很麻烦,特别是编译pdo_mysql后,还得手工加在php.ini中。
其实,可以在升级php版本同时把pdo_mysql也直接编译进去。只需要在./configure 后面的参数加上:–with-mysql=mysqlnd –with-mysqli=mysqlnd –with-pdo-mysql=mysqlnd即可。

以下从网上搜集整理后得出的结果,因各人的环境可能存在差异,不一定都能成功。网上大部分方法,都不完整。

WDCP中,把php5.2.17升级到5.3.17时,只需要:
wget http://pic.tsov.net/2014/php_up53.sh
sh php_up53.sh
此方式,不需要手工在php.ini加载pdo_mysql.so扩展。

重新安装memcache扩展:
wget http://pic.tsov.net/2014/memcached_ins.sh (因有资源在墙外,很多人下载失败;本站已下载放置在墙内,可以直接下载成功了。)
sh memcached_ins.sh
安装完后,检查下php.ini,看看是否加载了memcache.so扩展。

最后,重启一下:service httpd restart

相关日志

发表于:2014-12-12 22:57:35 at 22:57 分类:代码 发表评论 Tags:, , ,

发表评论

(必填)

(必填)您的电子邮箱不会被公开。

*

正在加载信息...

Archives